summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2019-10-15 15:15:40 +0300
committerGitHub <noreply@github.com>2019-10-15 15:15:40 +0300
commit16d40fbb14f29e51902434a5da69932c4b0353a0 (patch)
treea74e8306825cacd2672b60ed4ffc2908e47c2f72 /Makefile.am
parent8a2f99238aacc7ba5429e3942870ccc1e897be3a (diff)
Add CMocka unit tests (#6985)
* Add str2ld test * Build test with Autotools * Add storage_number test * Configure tests in CMake
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 35d9712cb0..a754bd26aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -637,3 +637,22 @@ if ENABLE_BACKEND_MONGODB
netdata_SOURCES += $(MONGODB_BACKEND_FILES)
netdata_LDADD += $(OPTIONAL_MONGOC_LIBS)
endif
+
+check_PROGRAMS = \
+ libnetdata/tests/str2ld_testdriver \
+ libnetdata/storage_number/tests/storage_number_testdriver \
+ $(NULL)
+
+TESTS = $(check_PROGRAMS)
+
+libnetdata_tests_str2ld_testdriver_SOURCES = \
+ libnetdata/tests/test_str2ld.c \
+ $(LIBNETDATA_FILES) \
+ $(NULL)
+libnetdata_tests_str2ld_testdriver_LDADD = $(NETDATA_COMMON_LIBS) $(TEST_LIBS)
+
+libnetdata_storage_number_tests_storage_number_testdriver_SOURCES = \
+ libnetdata/storage_number/tests/test_storage_number.c \
+ $(LIBNETDATA_FILES) \
+ $(NULL)
+libnetdata_storage_number_tests_storage_number_testdriver_LDADD = $(NETDATA_COMMON_LIBS) $(TEST_LIBS)