summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStelios Fragkakis <52996999+stelfrag@users.noreply.github.com>2023-09-01 17:35:39 +0300
committerGitHub <noreply@github.com>2023-09-01 17:35:39 +0300
commit0ba3827c53b753c493fed561be3a700e61751fa9 (patch)
tree619018a006f81e62fb55b3ad03e40ccf4da6624e /Makefile.am
parent6ee8ea23f32be1ce0e373f0c3822e415edd2db03 (diff)
Add better recovery for corrupted metadata (#15891)
* Add sqlite-meta-recover command line option Remove the old recovery that would attempt to fix only chart and dimension Mark recovery for metadata (for now) Simplify the database init function * Reduce variable scope, formatting
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e10ce0e8ae..38fb9cdb9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -505,6 +505,9 @@ RRD_PLUGIN_FILES = \
database/sqlite/sqlite_aclk_alert.h \
database/sqlite/sqlite3.c \
database/sqlite/sqlite3.h \
+ database/sqlite/sqlite3recover.c \
+ database/sqlite/sqlite3recover.h \
+ database/sqlite/dbdata.c \
database/KolmogorovSmirnovDist.c \
database/KolmogorovSmirnovDist.h \
$(NULL)