summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAdrien Mahieux <adrien.mahieux@gmail.com>2019-09-18 14:13:32 +0200
committerChris Akritidis <43294513+cakrit@users.noreply.github.com>2019-09-18 14:13:32 +0200
commit0942680f85a3fb0a03bc8c211fcc9d286572c242 (patch)
treef0d664bad2627e0bf488f970927be55c05c5b0d7 /Makefile.am
parenta3a46cb6d5147a1e8159de468523cd91d08bc2cf (diff)
Collector slabinfo (#6800)
### Summary Provide new collector parsing `/proc/slabinfo` to provide details on kernel slab structures. Asked by issue #13 (very happy for the oldest issue in backlog) ##### Component Name collectors/slabinfo.plugin ##### Additional Information This slabinfo details allows to have clues on actions done on your system. In the following screenshot, you can clearly see a `find` done on a ext4 filesystem (the number of `ext4_inode_cache` & `dentry` are rising fast), and a few seconds later, an admin issued a `echo 3 > /proc/sys/vm/drop_cached` as their count dropped.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e515db8d3..35d9712cb0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -236,6 +236,11 @@ NFACCT_PLUGIN_FILES = \
$(LIBNETDATA_FILES) \
$(NULL)
+SLABINFO_PLUGIN_FILES = \
+ collectors/slabinfo.plugin/slabinfo.c \
+ $(LIBNETDATA_FILES)
+ $(NULL)
+
XENSTAT_PLUGIN_FILES = \
collectors/xenstat.plugin/xenstat_plugin.c \
$(LIBNETDATA_FILES) \
@@ -600,6 +605,14 @@ if ENABLE_PLUGIN_PERF
$(NULL)
endif
+if ENABLE_PLUGIN_SLABINFO
+ plugins_PROGRAMS += slabinfo.plugin
+ slabinfo_plugin_SOURCES = $(SLABINFO_PLUGIN_FILES)
+ slabinfo_plugin_LDADD = \
+ $(NETDATA_COMMON_LIBS) \
+ $(NULL)
+endif
+
if ENABLE_BACKEND_KINESIS
netdata_SOURCES += $(KINESIS_BACKEND_FILES)
netdata_LDADD += $(OPTIONAL_KINESIS_LIBS)