summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Akritidis <43294513+cakrit@users.noreply.github.com>2019-01-15 12:49:28 +0100
committerGitHub <noreply@github.com>2019-01-15 12:49:28 +0100
commit08649bec373555144878b4314e87c9a8eb38c82e (patch)
tree23c9246e606f948944af8bc33f976085fa455848 /Makefile.am
parent67834f184ff3d67f6c8b6005ac68b568d7573118 (diff)
Port ACLs, Management API and Health commands (#4969)
##### Summary fixes #2673 fixes #2149 fixes #5017 fixes #3830 fixes #3187 fixes #5154 Implements a command API for health which will accept commands via a socket to selectively suppress health checks. Allows different ports to accept different request types (streaming, dashboard, api, registry, netdata.conf, badges, management) Removes support for multi-threaded and single-threaded web servers. ##### Component Name health, daemon
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 994b4260bd..a6998839ae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -337,6 +337,8 @@ API_PLUGIN_FILES = \
web/api/formatters/charts2json.h \
web/api/formatters/rrdset2json.c \
web/api/formatters/rrdset2json.h \
+ web/api/health/health_cmdapi.c \
+ web/api/health/health_cmdapi.h \
web/api/web_api_v1.c \
web/api/web_api_v1.h \
$(NULL)
@@ -374,10 +376,6 @@ WEB_PLUGIN_FILES = \
web/server/web_server.h \
web/server/web_client_cache.c \
web/server/web_client_cache.h \
- web/server/single/single-threaded.c \
- web/server/single/single-threaded.h \
- web/server/multi/multi-threaded.c \
- web/server/multi/multi-threaded.h \
web/server/static/static-threaded.c \
web/server/static/static-threaded.h \
$(NULL)