summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@tsaousis.gr>2016-09-30 14:49:19 +0300
committerCosta Tsaousis <costa@tsaousis.gr>2016-09-30 14:49:19 +0300
commitee7b844c041ec1453684dedefd3aed9e7de00c4d (patch)
tree7e4aa9b2befbae9257ec5d9994d5ab77ad1d692c /CMakeLists.txt
parent736937b3926814f792373885a9a0a4519bae7787 (diff)
fix unecessary calls to realloc(); added memory allocations logger - enabled with -DNETDATA_LOG_ALLOCATIONS=1
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a713732ce4..e973f6ebec 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,7 @@ project(netdata C)
find_package (Threads)
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wformat-signedness -Werror=format-security")
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wformat-signedness -Werror=format-security -DNETDATA_INTERNAL_CHECKS=1")
set(NETDATA_SOURCE_FILES
src/appconfig.c