summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarkos Fountoulakis <44345837+mfundul@users.noreply.github.com>2019-12-19 11:01:59 +0200
committerAndrew Moss <1043609+amoss@users.noreply.github.com>2019-12-19 10:01:59 +0100
commitce9f70d7b3696a54f099628f3337f5c4d5bd1407 (patch)
treed8f0e7bbdd1a070c2dcf619e62c6e5ff4faaccfc /CMakeLists.txt
parentc1436efd00c5b9afdb3779585eb194ea8388a932 (diff)
Agent claiming (#7525)
Initial infrastructure support for agent claiming. This feature is not currently enabled as we are still finalizing the details of the cloud infrastructure w.r.t. agent claiming. The feature will be enabled when we are ready to release it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ff64b1c38..fe221b9b0a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -601,6 +601,11 @@ set(BACKENDS_PLUGIN_FILES
backends/prometheus/backend_prometheus.h
)
+set(CLAIM_PLUGIN_FILES
+ claim/claim.c
+ claim/claim.h
+ )
+
set(EXPORTING_ENGINE_FILES
exporting/exporting_engine.c
exporting/exporting_engine.h
@@ -667,6 +672,7 @@ set(NETDATA_FILES
${STATSD_PLUGIN_FILES}
${STREAMING_PLUGIN_FILES}
${WEB_PLUGIN_FILES}
+ ${CLAIM_PLUGIN_FILES}
)
set(NETDATACLI_FILES