summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHaochen Tong <hexchain@users.noreply.github.com>2019-12-02 22:04:50 +0100
committerthiagoftsm <thiagoftsm@gmail.com>2019-12-02 21:04:50 +0000
commit8a70725c132deb6fc313edcdccaea756a685fc49 (patch)
treeed4c52d299be95ede4ee23970bd7edc777a27c0d /CMakeLists.txt
parent998470b66b3309b77db9b64d20a83e7aec8185be (diff)
proc.plugin: add pressure stall information (#7209)
* proc.plugin: add pressure stall information * dashboard_info: add "Pressure" section * proc.plugin: mention PSI collector in doc * dashboard_info: fix grammar in PSI section * proc_pressure: fix wrong line name for "full" metrics * proc_pressure: fix copypasta * proc_pressure: refactor to prepare for cgroup changes * cgroups.plugin: add pressure monitoring * add proc_pressure.h to targets * Makefile.am: fix indentation * cgroups.plugin: remove a useless comment * cgroups.plugin: fix pressure config name * proc.plugin: arrange pressure charts under corresponding sections * dashboard_info: rearrange pressure chart descriptions * dashboard_info: reword PSI descriptions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5e35dff6f3..f3989b4c47 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -438,6 +438,8 @@ set(PROC_PLUGIN_FILES
collectors/proc.plugin/proc_sys_kernel_random_entropy_avail.c
collectors/proc.plugin/proc_vmstat.c
collectors/proc.plugin/proc_uptime.c
+ collectors/proc.plugin/proc_pressure.c
+ collectors/proc.plugin/proc_pressure.h
collectors/proc.plugin/sys_kernel_mm_ksm.c
collectors/proc.plugin/sys_block_zram.c
collectors/proc.plugin/sys_devices_system_edac_mc.c