summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@tsaousis.gr>2018-09-20 19:45:41 +0300
committerGitHub <noreply@github.com>2018-09-20 19:45:41 +0300
commit2b14e31befc080c7c65fd4c53ed22852f28796de (patch)
tree1d0e4fcaf7baa5644d09e80d729a530ecf4a18c6 /CMakeLists.txt
parent35caecc3ba869d7b958a9e1ae6f1799665e7da32 (diff)
daemon cleanup (#4231)
* c code cleanup; eliminate all errors and warning under clion * removed old server API * removed obsolete "file" API command * included common.h everywhere * fix for github syntax highlighting * enable CLion to build all netdata binaries * added locks verification to cmake
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt24
1 files changed, 17 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5320013df5..927495be61 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,7 @@ project(netdata C)
find_package (Threads)
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wformat-signedness -Werror=format-security -DNETDATA_INTERNAL_CHECKS=1 -fstack-protector-all")
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wformat-signedness -Werror=format-security -DNETDATA_INTERNAL_CHECKS=1 -DNETDATA_VERIFY_LOCKS=1 -fstack-protector-all")
set(NETDATA_FREEBSD_FILES
src/plugin_freebsd.c
@@ -136,8 +136,6 @@ set(NETDATA_COMMON_FILES
src/rrd.h
src/rrd2json.c
src/rrd2json.h
- src/rrd2json_api_old.c
- src/rrd2json_api_old.h
src/rrdcalc.c
src/rrdcalctemplate.c
src/rrddim.c
@@ -167,8 +165,6 @@ set(NETDATA_COMMON_FILES
src/unit_test.h
src/url.c
src/url.h
- src/web_api_old.c
- src/web_api_old.h
src/web_api_v1.c
src/web_api_v1.h
src/web_buffer.c
@@ -188,6 +184,8 @@ set(APPS_PLUGIN_SOURCE_FILES
src/apps_plugin.c
src/avl.c
src/avl.h
+ src/adaptive_resortable_list.c
+ src/adaptive_resortable_list.h
src/common.c
src/common.h
src/clocks.c
@@ -199,6 +197,8 @@ set(APPS_PLUGIN_SOURCE_FILES
src/log.h
src/procfile.c
src/procfile.h
+ src/threads.c
+ src/threads.h
src/web_buffer.c
src/web_buffer.h
config.h
@@ -217,6 +217,8 @@ set(FREEIPMI_PLUGIN_SOURCE_FILES
src/log.h
src/procfile.c
src/procfile.h
+ src/threads.c
+ src/threads.h
config.h
)
@@ -231,8 +233,16 @@ set(CGROUP_NETWORK_SOURCE_FILES
src/locks.h
src/log.c
src/log.h
+ src/popen.c
+ src/popen.h
src/procfile.c
src/procfile.h
+ src/signals.c
+ src/signals.h
+ src/storage_number.c
+ src/storage_number.h
+ src/threads.c
+ src/threads.h
src/web_buffer.c
src/web_buffer.h
config.h
@@ -252,10 +262,10 @@ add_executable(netdata_macos ${NETDATA_COMMON_FILES} ${NETDATA_MACOS_FILES})
target_link_libraries (netdata_macos m z uuid ${CMAKE_THREAD_LIBS_INIT})
add_executable(apps.plugin ${APPS_PLUGIN_SOURCE_FILES} src/inlined.h)
-target_link_libraries (apps.plugin m ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries (apps.plugin m cap ${CMAKE_THREAD_LIBS_INIT})
add_executable(freeipmi.plugin ${FREEIPMI_PLUGIN_SOURCE_FILES})
-target_link_libraries (freeipmi.plugin ipmimonitoring)
+target_link_libraries (freeipmi.plugin ipmimonitoring ${CMAKE_THREAD_LIBS_INIT})
add_executable(cgroup-network ${CGROUP_NETWORK_SOURCE_FILES})
target_link_libraries (cgroup-network m ${CMAKE_THREAD_LIBS_INIT})