summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladimir Kobal <vlad@prokk.net>2020-04-10 12:26:36 +0300
committerGitHub <noreply@github.com>2020-04-10 12:26:36 +0300
commit231d19351d0ea20aa66fd204215cbb24f34d7575 (patch)
treee3ed26be7d8ea4ba3b07a29c77bf05bc67b73a43 /CMakeLists.txt
parent764a0676e82c89b4a4516a31a7782ea606071fa5 (diff)
Show internal stats for the exporting engine (#8635)
* Add a print function for internal exporting statistics * Send statistics for simple connectors * Flush sending buffers on failures * Send statistics for the Kinesis connector * Send statistics for the MongoDB connector * Add unit tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c5254b6e6..ca0ab99946 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1112,6 +1112,8 @@ endif()
-Wl,--wrap=recv
-Wl,--wrap=send
-Wl,--wrap=connect_to_one_of
+ -Wl,--wrap=create_main_rusage_chart
+ -Wl,--wrap=send_main_rusage
${PROMETHEUS_REMOTE_WRITE_LINK_OPTIONS}
${KINESIS_LINK_OPTIONS}
${MONGODB_LINK_OPTIONS}