summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCosta Tsaousis (ktsaou) <costa@tsaousis.gr>2017-07-30 19:29:46 +0300
committerCosta Tsaousis (ktsaou) <costa@tsaousis.gr>2017-07-30 19:29:46 +0300
commit012d456f385f1d629d9110bd0a0aa5bcd52c59e7 (patch)
treed7bb52f835f3d445a4a300c611975abc8cb6e1e6 /CMakeLists.txt
parentd2e9b448afc21ae82444702ca2280d00796eab55 (diff)
added cgroup-network that can find the network interface of a cgroup, given a pid in it
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e59e094d8..0d926c189d 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -188,6 +188,22 @@ set(FREEIPMI_PLUGIN_SOURCE_FILES
config.h
)
+set(CGROUP_NETWORK_SOURCE_FILES
+ src/cgroup-network.c
+ src/common.c
+ src/common.h
+ src/clocks.c
+ src/clocks.h
+ src/inlined.h
+ src/log.c
+ src/log.h
+ src/procfile.c
+ src/procfile.h
+ src/web_buffer.c
+ src/web_buffer.h
+ config.h
+ )
+
include_directories(AFTER .)
add_definitions(-DHAVE_CONFIG_H -DCACHE_DIR="/var/cache/netdata" -DCONFIG_DIR="/etc/netdata" -DLOG_DIR="/var/log/netdata" -DPLUGINS_DIR="/usr/libexec/netdata" -DWEB_DIR="/usr/share/netdata" -DVARLIB_DIR="/var/lib/netdata")
@@ -200,3 +216,6 @@ target_link_libraries (apps.plugin m ${CMAKE_THREAD_LIBS_INIT})
add_executable(freeipmi.plugin ${FREEIPMI_PLUGIN_SOURCE_FILES})
target_link_libraries (freeipmi.plugin ipmimonitoring)
+
+add_executable(cgroup-network ${CGROUP_NETWORK_SOURCE_FILES})
+target_link_libraries (cgroup-network m ${CMAKE_THREAD_LIBS_INIT})