summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPavlos Emm. Katsoulakis <paul@netdata.rocks>2019-06-28 08:27:57 +0200
committerPavlos Emm. Katsoulakis <paul@netdata.rocks>2019-06-28 08:27:57 +0200
commit171d8f5d01f17dddbd531139b86e1a1c96f95b0d (patch)
tree7b2f049259656e4c14c3d7e23a639964ebb2e07b /CMakeLists.txt
parent5d5266dc1a863d877d91cab232b6369091a198ee (diff)
Revert "Easily disable alarms, by persisting the silencers configuration (#6274)"
This reverts commit 60a73e90de2aa1c2eaae2ebbc45dd1fb96034df2. Emergency rollback of potential culprit as per issue #6356 Will be re-merging the change after investigation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 1 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a90d680d9..e6109c2fc2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -131,14 +131,6 @@ set(NETDATA_COMMON_LIBRARIES ${NETDATA_COMMON_LIBRARIES} ${OPENSSL_LIBRARIES})
set(NETDATA_COMMON_INCLUDE_DIRS ${NETDATA_COMMON_INCLUDE_DIRS} ${OPENSSL_INCLUDE_DIRS})
# -----------------------------------------------------------------------------
-# JSON-C used to health
-
-pkg_check_modules(JSON REQUIRED json-c)
-set(NETDATA_COMMON_CFLAGS ${NETDATA_COMMON_CFLAGS} ${JSONC_CFLAGS_OTHER})
-set(NETDATA_COMMON_LIBRARIES ${NETDATA_COMMON_LIBRARIES} ${JSON_LIBRARIES})
-set(NETDATA_COMMON_INCLUDE_DIRS ${NETDATA_COMMON_INCLUDE_DIRS} ${JSON_INCLUDE_DIRS})
-
-# -----------------------------------------------------------------------------
# Detect libcap
IF(LINUX)
@@ -313,15 +305,8 @@ set(LIBNETDATA_FILES
libnetdata/threads/threads.h
libnetdata/url/url.c
libnetdata/url/url.h
- libnetdata/health/health.c
- libnetdata/health/health.h
libnetdata/socket/security.c
- libnetdata/socket/security.h
- libnetdata/json/json.c
- libnetdata/json/json.h
- libnetdata/json/jsmn.c
- libnetdata/json/jsmn.h
- )
+ libnetdata/socket/security.h)
add_library(libnetdata OBJECT ${LIBNETDATA_FILES})