summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorthiagoftsm <thiagoftsm@gmail.com>2023-05-15 16:06:26 +0000
committerGitHub <noreply@github.com>2023-05-15 19:06:26 +0300
commit588096c6b682ec467d85656abab65d77f74e5755 (patch)
tree64d88be9c0ec23c5d79370cc1bed826e19a2b51a /CMakeLists.txt
parentbdc40c318a761f5e05e3544b72c4aa3384484e44 (diff)
Debugfs collector (#15017)
Co-authored-by: Fotis Voutsas <fotis@netdata.cloud> Co-authored-by: Austin S. Hemmelgarn <ahferroin7@gmail.com> Co-authored-by: ilyam8 <ilya@netdata.cloud>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 530248fa21..85161c6d3b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -507,6 +507,13 @@ target_include_directories(libnetdata BEFORE PUBLIC ${GENERATED_CONFIG_H_DIR})
set(APPS_PLUGIN_FILES
collectors/apps.plugin/apps_plugin.c)
+set(DEBUGFS_PLUGIN_FILES
+ collectors/debugfs.plugin/debugfs_plugin.c
+ collectors/debugfs.plugin/debugfs_plugin.h
+ collectors/debugfs.plugin/debugfs_extfrag.c
+ collectors/debugfs.plugin/debugfs_zswap.c
+ )
+
set(FREEBSD_PLUGIN_FILES
collectors/freebsd.plugin/plugin_freebsd.c
collectors/freebsd.plugin/plugin_freebsd.h
@@ -1364,6 +1371,21 @@ target_compile_options(netdatacli PUBLIC ${NETDATA_COMMON_CFLAGS})
# -----------------------------------------------------------------------------
+# debugfs.plugin
+
+IF(ENABLE_PLUGIN_DEBUGFS)
+ message(STATUS "debugfs.plugin: enabled")
+ add_executable(debugfs.plugin ${GENERATED_CONFIG_H} ${DEBUGFS_PLUGIN_FILES})
+ target_link_libraries (debugfs.plugin libnetdata ${NETDATA_COMMON_LIBRARIES} ${CAP_LIBRARIES})
+ target_include_directories(debugfs.plugin PUBLIC ${NETDATA_COMMON_INCLUDE_DIRS} ${CAP_INCLUDE_DIRS})
+ target_include_directories(debugfs.plugin BEFORE PUBLIC ${GENERATED_CONFIG_H_DIR})
+ target_compile_options(debugfs.plugin PUBLIC ${NETDATA_COMMON_CFLAGS} ${CAP_CFLAGS_OTHER})
+ELSE()
+ message(STATUS "debugfs.plugin: disabled")
+ENDIF()
+
+
+# -----------------------------------------------------------------------------
# apps.plugin
IF(ENABLE_PLUGIN_APPS)