summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIlya Mashchenko <ilya@netdata.cloud>2024-03-05 16:40:19 +0200
committerGitHub <noreply@github.com>2024-03-05 16:40:19 +0200
commit4c1adba5073294537f7233634ad15684018a42cf (patch)
treef2fc7526e8cc585187e4006c4126f42c0f54b3a1 /CMakeLists.txt
parentd8827d1e5ff927623d16b2e67ad9123e5f5b24ea (diff)
go.d.plugin dyncfgv2 (#17064)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4fce843857..f875293cfc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2671,14 +2671,22 @@ if(ENABLE_PLUGIN_GO)
install(FILES src/go/collectors/go.d.plugin/config/go.d.conf
COMPONENT go.d.plugin
DESTINATION usr/lib/netdata/conf.d)
+
install(DIRECTORY
COMPONENT go.d.plugin
DESTINATION usr/lib/netdata/conf.d/go.d)
-
file(GLOB GO_CONF_FILES src/go/collectors/go.d.plugin/config/go.d/*.conf)
install(FILES ${GO_CONF_FILES}
COMPONENT go.d.plugin
DESTINATION usr/lib/netdata/conf.d/go.d)
+
+ install(DIRECTORY
+ COMPONENT go.d.plugin
+ DESTINATION usr/lib/netdata/conf.d/go.d/sd)
+ file(GLOB GO_SD_CONF_FILES src/go/collectors/go.d.plugin/config/go.d/sd/*.conf)
+ install(FILES ${GO_SD_CONF_FILES}
+ COMPONENT go.d.plugin
+ DESTINATION usr/lib/netdata/conf.d/go.d/sd)
endif()
#