summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2023-01-23 19:59:29 +0700
committerGitHub <noreply@github.com>2023-01-23 19:59:29 +0700
commitc2c3876c519fbc22a60a5d8b753dc6d8e81e0fed (patch)
tree4225588f7474145ecc6968ea4a65ce6cae269d99 /CMakeLists.txt
parent5fabd2548ca342e9133add357bf160c67c6de079 (diff)
remove mqtt-c from websockets (#14181)
* remove MQTT-C (MQTT 3 implementation) from buildsystem
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 118b2f0313..a4c6a08335 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -944,8 +944,6 @@ set(MQTT_WEBSOCKETS_FILES
mqtt_websockets/c-rbuf/src/ringbuffer.c
mqtt_websockets/c-rbuf/include/ringbuffer.h
mqtt_websockets/c-rbuf/src/ringbuffer_internal.h
- mqtt_websockets/MQTT-C/src/mqtt.c
- mqtt_websockets/MQTT-C/include/mqtt.h
)
set(SPAWN_PLUGIN_FILES
@@ -1273,7 +1271,6 @@ list(APPEND NETDATA_COMMON_INCLUDE_DIRS ${PROTOBUF_INCLUDE_DIRS})
list(APPEND NETDATA_COMMON_CFLAGS ${PROTOBUF_CFLAGS_OTHER})
list(APPEND NETDATA_FILES ${ACLK_FILES} ${ACLK_PROTO_BUILT_SRCS} ${ACLK_PROTO_BUILT_HDRS})
include_directories(BEFORE ${CMAKE_SOURCE_DIR}/aclk/aclk-schemas)
-include_directories(BEFORE ${CMAKE_SOURCE_DIR}/mqtt_websockets/MQTT-C/include)
include_directories(BEFORE ${CMAKE_SOURCE_DIR}/mqtt_websockets/src/include)
include_directories(BEFORE ${CMAKE_SOURCE_DIR}/mqtt_websockets/c-rbuf/include)