summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@netdata.cloud>2022-07-08 00:09:33 +0300
committerGitHub <noreply@github.com>2022-07-08 00:09:33 +0300
commita6da6beb71f31ed5e89d9ed7a5a7d3242cdd8d8e (patch)
tree823697f4efceffb661f3080309ae737354c4bf39 /CMakeLists.txt
parent7f144682083bb334d38a527e7c9bd4bc736575eb (diff)
array allocator for dbengine page descriptors (#13312)
* array allocator for dbengine page descriptors * full implementation of array allocator with cleanup * faster deallocations * eliminate entierely the need for loops during free * addressed comments * lower the min number of elements to 10
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd48820cf3..9d459b7fce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -370,6 +370,8 @@ set(LIBNETDATA_FILES
libnetdata/adaptive_resortable_list/adaptive_resortable_list.h
libnetdata/config/appconfig.c
libnetdata/config/appconfig.h
+ libnetdata/arrayalloc/arrayalloc.c
+ libnetdata/arrayalloc/arrayalloc.h
libnetdata/avl/avl.c
libnetdata/avl/avl.h
libnetdata/buffer/buffer.c