summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVilkov Adel <vilkov.adel@gmail.com>2019-08-12 11:01:09 +0300
committerVladimir Kobal <vlad@prokk.net>2019-08-12 11:01:09 +0300
commit8bf966d6e06281e03333742c5d650bfe60b51ded (patch)
tree75aaa5d42818858eb7f42ffced9f2028847081bc /CMakeLists.txt
parent4e4f95411be93a83b18fc10b768263a3cd749508 (diff)
(re-open) ZRAM info collector module (proc.plugin) (#6424)
* ZRAM collector module ZRAM: Implemented zram device id detection ZRAM: Implemented zram device enumeration WIP ZRAM: Memory usage graph (needs other graphs) ZRAM: Added ratio and efficiency graph ZRAM: Added chart description and context names, code formatting * ZRAM: Proper handling of zram device removal * ZRAM: Added additional checks, removed redundant logging
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4d631f2fe7..13a9f472c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -423,6 +423,7 @@ set(PROC_PLUGIN_FILES
collectors/proc.plugin/proc_vmstat.c
collectors/proc.plugin/proc_uptime.c
collectors/proc.plugin/sys_kernel_mm_ksm.c
+ collectors/proc.plugin/sys_block_zram.c
collectors/proc.plugin/sys_devices_system_edac_mc.c
collectors/proc.plugin/sys_devices_system_node.c
collectors/proc.plugin/sys_fs_btrfs.c