summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCosta Tsaousis <costa@netdata.cloud>2022-05-03 00:31:19 +0300
committerGitHub <noreply@github.com>2022-05-03 00:31:19 +0300
commit87c0cc2d6049c46f38b9c866668a0a24a3e962c0 (patch)
tree066c18bc90894e89ce46dc0b2e104c61018e830c /CMakeLists.txt
parent47fa3d708902fb001b2e88e4145d2a451549cd8e (diff)
One way allocator to double the speed of parallel context queries (#12787)
* one way allocator to speed up context queries * fixed a bug while expanding memory pages * reworked for clarity and finally fixed the bug of allocating memory beyond the page size * further optimize allocation step to minimize the number of allocations made * implement strdup with memcpy instead of strcpy * added documentation * prevent an uninitialized use of owa * added callocz() interface * integrate onewayalloc everywhere - apart sql queries * one way allocator is now used in context queries using archived charts in sql * align on the size of pointers * forgotten freez() * removed not needed memcpys * give unique names to global variables to avoid conflicts with system definitions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f3df9feff1..87d293ddb2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -383,6 +383,8 @@ set(LIBNETDATA_FILES
libnetdata/log/log.h
libnetdata/os.c
libnetdata/os.h
+ libnetdata/onewayalloc/onewayalloc.c
+ libnetdata/onewayalloc/onewayalloc.h
libnetdata/popen/popen.c
libnetdata/popen/popen.h
libnetdata/procfile/procfile.c