summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStelios Fragkakis <52996999+stelfrag@users.noreply.github.com>2023-02-14 19:48:10 +0200
committerGitHub <noreply@github.com>2023-02-14 19:48:10 +0200
commit8479be80c9ae1957b0e129c133f000e3460404f4 (patch)
treea96b8b4affafe155c0544fcf147d9106a708b28a /CMakeLists.txt
parent960f8da6634c58636139bbc77c00d51dbe6ed0d3 (diff)
Simplify parser README.md and add parser files to CMakeLists.txt (#14523)
Add parser in CMakeLists.txt Keep minimal documentation (overview) and refer to the actual code
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 263fb81256..c9fee2a08e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -512,6 +512,8 @@ set(LIBNETDATA_FILES
libnetdata/string/utf8.h
libnetdata/worker_utilization/worker_utilization.c
libnetdata/worker_utilization/worker_utilization.h
+ libnetdata/parser/parser.h
+ libnetdata/parser/parser.c
)
IF(ENABLE_PLUGIN_EBPF)
@@ -695,11 +697,6 @@ set(PLUGINSD_PLUGIN_FILES
collectors/plugins.d/pluginsd_parser.h
)
-set(PARSER_PLUGIN_FILES
- parser/parser.c
- parser/parser.h
- )
-
set(REGISTRY_PLUGIN_FILES
registry/registry.c
registry/registry.h
@@ -1077,7 +1074,6 @@ set(NETDATA_FILES
${WEB_PLUGIN_FILES}
${CLAIM_PLUGIN_FILES}
${SPAWN_PLUGIN_FILES}
- ${PARSER_PLUGIN_FILES}
)
set(NETDATACLI_FILES