summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2022-08-25 14:57:01 +0200
committerGitHub <noreply@github.com>2022-08-25 14:57:01 +0200
commit3e233a3e061b0915defe13de05ee9d283789df1b (patch)
treea0e2d9899592e3a9f1cf7d08937a9da81f63b77c /CMakeLists.txt
parent142e2ee23d57ff769a00027e5fa0c13c71ec0b63 (diff)
minor - eBPF cmake missing include dir (#13568)
add missing include dir
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 901023fd1f..8143e5b694 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -328,7 +328,7 @@ IF(LINUX AND EXISTS "${CMAKE_SOURCE_DIR}/externaldeps/libbpf/libbpf.a")
${CMAKE_SOURCE_DIR}/externaldeps/libbpf/libbpf.a
${ELF_LIBRARIES})
list(APPEND NETDATA_COMMON_INCLUDE_DIRS ${ELF_INCLUDE_DIRS})
- include_directories(BEFORE ${CMAKE_SOURCE_DIR}/externaldeps/libbpf/include)
+ include_directories(BEFORE ${CMAKE_SOURCE_DIR}/externaldeps/libbpf/include ${CMAKE_SOURCE_DIR}/externaldeps/libbpf/include/uapi)
set(ENABLE_PLUGIN_EBPF True)
ELSE(ELF_LIBRARIES)
set(ENABLE_PLUGIN_EBPF False)