summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarkos Fountoulakis <44345837+mfundul@users.noreply.github.com>2019-12-05 00:21:22 +0200
committerChris Akritidis <43294513+cakrit@users.noreply.github.com>2019-12-04 14:21:22 -0800
commit16f835489c1a93b5dbd84747c52c883f43b716f0 (patch)
treefe91de0b4fa0d85f52870550e410bc1d0dead434 /CMakeLists.txt
parenta7a88ba2723242da1de6626df0541d2091bd9b2b (diff)
Implement netdata command server and cli tool (#7325)
* Checkpoint commit (POC) * Implemented command server in the daemon * Add netdatacli implementation * Added prints in command server setup functions * Make libuv version 1 a hard dependency for the agent * Additional documentation * Improved accuracy of names and documentation * Fixed documentation * Fixed buffer overflow * Added support for exit status in cli. Added prefixes for exit code, stdout and stderr. Fixed parsers. * Fix compilation errors * Fix compile errors * Fix compile errors * Fix compile error * Fix linker error for muslc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f3989b4c47..9eaa015838 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -628,6 +628,8 @@ set(DAEMON_FILES
daemon/main.h
daemon/signals.c
daemon/signals.h
+ daemon/commands.c
+ daemon/commands.h
daemon/unit_test.c
daemon/unit_test.h
)
@@ -648,6 +650,12 @@ set(NETDATA_FILES
${WEB_PLUGIN_FILES}
)
+set(NETDATACLI_FILES
+ daemon/commands.h
+ cli/cli.c
+ cli/cli.h
+ )
+
include_directories(AFTER .)
add_definitions(
@@ -785,6 +793,15 @@ ENDIF()
# -----------------------------------------------------------------------------
+# netdatacli
+
+add_executable(netdatacli config.h ${NETDATACLI_FILES})
+target_link_libraries (netdatacli libnetdata ${NETDATA_COMMON_LIBRARIES})
+target_include_directories(netdatacli PUBLIC ${NETDATA_COMMON_INCLUDE_DIRS})
+target_compile_options(netdatacli PUBLIC ${NETDATA_COMMON_CFLAGS})
+
+
+# -----------------------------------------------------------------------------
# apps.plugin
IF(ENABLE_PLUGIN_APPS)