summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimotej S <6674623+underhood@users.noreply.github.com>2022-06-06 12:05:32 +0200
committerGitHub <noreply@github.com>2022-06-06 12:05:32 +0200
commit123e923f76ad2cc458dd98b01ba8b29f2306bee2 (patch)
tree3f57835986e0381c6ab973b142ad8c42398f82f5 /CMakeLists.txt
parente6f1aeb54c5b17f7ad5315fd97c6e1dcdd03207e (diff)
Allow usage of the new MQTT 5 implementation (#12838)
* adds support for new MQTT5 implementation in agent, currently by default disabled as Tech Preview
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cd5d68a8c5..378e8a6832 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -817,6 +817,11 @@ set(ACLK_FILES
mqtt_websockets/src/include/mqtt_wss_log.h
mqtt_websockets/src/ws_client.c
mqtt_websockets/src/include/ws_client.h
+ mqtt_websockets/src/mqtt_ng.c
+ mqtt_websockets/src/include/mqtt_ng.h
+ mqtt_websockets/src/common_public.c
+ mqtt_websockets/src/include/common_public.h
+ mqtt_websockets/src/include/common_internal.h
mqtt_websockets/c-rbuf/src/ringbuffer.c
mqtt_websockets/c-rbuf/include/ringbuffer.h
mqtt_websockets/c-rbuf/src/ringbuffer_internal.h