summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimo <6674623+underhood@users.noreply.github.com>2020-03-15 20:35:18 +0100
committerGitHub <noreply@github.com>2020-03-15 20:35:18 +0100
commit10090b556b07463a0ca2412fc4be8b470d115e31 (patch)
tree84b7b82daa83bf915d293c68deedeb524a317bd1 /CMakeLists.txt
parent9aab12387a6394dd7b07e8e3a1b0208ba650da3a (diff)
Support SOCKS5 in ACLK Challenge/Response and rewrite with LWS (#8404)
* wip * add alpn * beggining of cleanup * move common code * add SOCKS5 support * check HTTP response code * add timeout * separate https_client into own files * fix some mem leaks from master + avoid string copying and alloc/free * fix some PR unrelated warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 55ddfaaf76..ca25bd5cc2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -616,6 +616,8 @@ set(ACLK_PLUGIN_FILES
aclk/agent_cloud_link.h
aclk/aclk_lws_wss_client.c
aclk/aclk_lws_wss_client.h
+ aclk/aclk_lws_https_client.c
+ aclk/aclk_lws_https_client.h
aclk/mqtt.c
aclk/mqtt.h
)