summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorUlrich Kautz <ulrichkautz@fb.com>2022-02-09 10:23:50 +0000
committerUlrich Kautz <ulrichkautz@fb.com>2022-02-09 10:23:50 +0000
commitb5b79b4bf24ecc223fc48b9dce375d73ff8c9dd9 (patch)
tree83392c9f256a15cdf9b81592a00ef961cdbb375b /Cargo.toml
parentf86f9dd72e6b10a58df98258994ca4ff476e029a (diff)
Add build feature to disable repo management
Having a command to install cheatsheets from repositories on github is amazing and makes `navi` very easy to setup and get started. The repo contents provide the "meat" of `navi`. A one-liner can load a bunch of useful cheatsheets for a whole host of open source commands. However, in locked down environments, where a high level of control of what is executed needs to be imposed, having the capability to download and use "arbitrary code from the internet" can be more harmful than good. Here you would likely want to manage all cheathsheets for `navi` carefully yourself. Possibly reviewing each cheathsheet individually. This CL provides a build feature that disables the whole `repo` sub-command tree to support that use-case.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index aacd0f4..ecdf330 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,6 +13,7 @@ license = "Apache-2.0"
[features]
disable-command-execution = []
+disable-repo-management = []
[badges]
travis-ci = { repository = "denisidoro/navi", branch = "master" }