summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWill Fiveash <Will.Fiveash@Sun.COM>2010-03-08 14:04:23 -0600
committerWill Fiveash <Will.Fiveash@Sun.COM>2010-03-08 14:04:23 -0600
commit8f395807c549044dd6cc78c097ddc43bc8065efe (patch)
tree528e890f90e4bab0a698abf2732ff666591c38b1 /configure.ac
parent7b9109860a69079f85f58e5b969745b5a27a5946 (diff)
OpenSolaris sasl fix for configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 60d5757d..24f2cb0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -718,7 +718,7 @@ fi
AM_CONDITIONAL(USE_SSL, test x$need_ssl = xyes)
-AC_ARG_WITH(sasl, AC_HELP_STRING([--with-sasl@<:@=PFX@:>@], [Use Cyrus SASL 2 network security library]),
+AC_ARG_WITH(sasl, AC_HELP_STRING([--with-sasl@<:@=PFX@:>@], [Use SASL network security library]),
[
if test "$with_sasl" != "no"
then
@@ -734,15 +734,18 @@ AC_ARG_WITH(sasl, AC_HELP_STRING([--with-sasl@<:@=PFX@:>@], [Use Cyrus SASL 2 ne
fi
saved_LIBS="$LIBS"
+ LIBS=
- AC_CHECK_LIB(sasl2, sasl_client_init,,
- AC_MSG_ERROR([could not find libsasl2]),)
+ sasl_libs="sasl2 sasl"
+ AC_SEARCH_LIBS(sasl_encode64, [$sasl_libs],,
+ AC_MSG_ERROR([could not find sasl lib]),)
+ MUTTLIBS="$MUTTLIBS $LIBS"
MUTT_LIB_OBJECTS="$MUTT_LIB_OBJECTS mutt_sasl.o"
- MUTTLIBS="$MUTTLIBS -lsasl2"
LIBS="$saved_LIBS"
+
AC_DEFINE(USE_SASL,1,
- [ Define if want to use the Cyrus SASL library for POP/IMAP authentication. ])
+ [ Define if want to use the SASL library for POP/IMAP authentication. ])
need_sasl=yes
fi
])