summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin McCarthy <kevin@8t8.us>2015-07-02 11:21:19 -0700
committerKevin McCarthy <kevin@8t8.us>2015-07-02 11:21:19 -0700
commit049af0ec063f472db509204ae6dab70bcec5949a (patch)
treea5d3c7bfe184b7c5d23a2363b6b05f3b90d94b1e /configure.ac
parent8a07da9fd6f77c10c1183bbeb70bcfe4f4c85a84 (diff)
Convert from using mkinstalldirs to $(MKDIR_P).
The automake mkinstalldirs script is now deprecated. "install-sh -d" can be used in place. Configure.ac already includes AC_PROG_INSTALL, which will ensure install-sh is bundled. Add AC_PROG_MKDIR_P, which will set $(MKDIR_P) to either a thread-safe "mkdir -p" or will fall back to using install-sh.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c867af17..e0d6814a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,7 @@ fi
AC_PROG_CPP
AC_PROG_MAKE_SET
AC_PROG_INSTALL
+AC_PROG_MKDIR_P
AC_PROG_RANLIB
AC_CHECK_TOOL(AR, ar, ar)