summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin McCarthy <kevin@8t8.us>2021-01-03 15:33:46 -0800
committerKevin McCarthy <kevin@8t8.us>2021-01-03 15:37:22 -0800
commita3db7ccb0e9b7bcb63bb5ae161217a020d2b85e6 (patch)
tree921f9cf5a41023b351947825bd1563623fb45571 /configure.ac
parente4a8abe80f7c3dfc06da1e4bf2cb1d607cae60fc (diff)
Add configure checks for gssapi library and functions.
rkta on irc reported a build failure because the gss headers were not present. Add explicit checks for the required headers. Also add a check for gss_init_sec_context() when using the output of krb-config to configure flags. Abort configure if the library/header checks don't pass. It would previously continue on, setting USE_GSS and need_gss, which would just result in a build error.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9668b77e..52b104bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -742,7 +742,7 @@ then
if test "$GSSAPI_IMPL" = "none"
then
AC_CACHE_SAVE
- AC_MSG_RESULT([GSSAPI libraries not found])
+ AC_MSG_ERROR([GSSAPI libraries not found])
fi
if test "$GSSAPI_IMPL" = "Heimdal"
then