summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRemco Rijnders <remco@webconquest.com>2020-05-29 15:46:29 -0400
committerKevin McCarthy <kevin@8t8.us>2020-05-29 15:15:04 -0700
commit4091cbcd0cba5b1a078cc6ca003f1e0466c10152 (patch)
treed84036b78492ef8c10b57c7120537cb3c79bad94 /configure.ac
parente2d27aac500946560a40b49a4311f62d6b1db4b8 (diff)
Remove support for OpenSSL <0.9.5
The current code provides a workaround for the absence of RAND_status in OpenSSL versions before 0.9.5. The comments in the code indicate these versions have to be supported, but as these versions are now more than 20 years old, this no longer applies. Removing this support simplifies the code and on the small chance that anyone is still using such old versions, breaking their build will actually be doing them a favor given the known issues with these OpenSSL versions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7906ce35..3496ffd7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -813,7 +813,7 @@ AC_ARG_WITH(ssl, AS_HELP_STRING([--with-ssl@<:@=PFX@:>@],[Enable TLS support usi
AC_MSG_ERROR([Unable to find SSL library]), [$crypto_libs])
LIBS="$LIBS $crypto_libs"
- AC_CHECK_FUNCS(RAND_status RAND_egd)
+ AC_CHECK_FUNCS(RAND_egd)
AC_CHECK_DECLS([SSL_set_mode, SSL_MODE_AUTO_RETRY],,
AC_MSG_ERROR([Unable to find decent SSL header]), [[#include <openssl/ssl.h>]])