summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTAKAHASHI Tamotsu <ttakah@lapis.plala.or.jp>2008-11-16 20:34:19 -0800
committerTAKAHASHI Tamotsu <ttakah@lapis.plala.or.jp>2008-11-16 20:34:19 -0800
commit15ef00fcadb019b66f937d6bfc574bed23b0b21e (patch)
treed957df23b2ddb75a00da8652168cf42018eabe03 /configure.ac
parent3835962fcd69d8f9b60718a2fab4e1ef96af6ef6 (diff)
Add --disable-full-doc flag to only build documentation for enabled features
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4322bf20..80566d0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1289,6 +1289,16 @@ then
fi
AC_SUBST(DSLROOT)
+AC_ARG_ENABLE(full_doc,
+ AC_HELP_STRING([--disable-full-doc], [Omit disabled variables]),
+[ if test x$enableval = xno ; then
+ full_doc=no
+ fi
+])
+if test x$full_doc != xno ; then
+ AC_DEFINE(MAKEDOC_FULL,1, [Define if you want complete documentation.])
+fi
+
AC_OUTPUT(Makefile contrib/Makefile doc/Makefile imap/Makefile
intl/Makefile m4/Makefile po/Makefile.in
hcachever.sh muttbug.sh doc/instdoc.sh)