summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Roessler <roessler@does-not-exist.org>2003-03-03 14:01:06 +0000
committerThomas Roessler <roessler@does-not-exist.org>2003-03-03 14:01:06 +0000
commitd044f05207a3eea8124b2029c4b04826b9f14003 (patch)
tree096b05db63f07f52223c1215e6531dce5a9e20e8 /Makefile.am
parente8b857a970452e6301b3e937002b623f2684334e (diff)
IDN support for e-mail messages. Things should work automagically
once you have the GNU IDN library available from ftp://alpha.gnu.org/pub/gnu/libidn/ installed. For IDN's which can't be losslessly recoded to your local character set, mutt should automatically fall back to using the ASCII representation. There's probably a considerable number of bugs in this, and the code may, at this point, not even compile on machines without libidn. Will start working on that ASAP.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index cf172649..a1bec37f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,7 +28,7 @@ mutt_SOURCES = $(BUILT_SOURCES) \
score.c send.c sendlib.c signal.c sort.c \
status.c system.c thread.c charset.c history.c lib.c \
muttlib.c editmsg.c utf8.c mbyte.c wcwidth.c \
- url.c ascii.c
+ url.c ascii.c mutt_idna.c
mutt_LDADD = @MUTT_LIB_OBJECTS@ @LIBOBJS@ $(LIBIMAP) $(MUTTLIBS) \
$(INTLLIBS) $(LIBICONV)
@@ -61,7 +61,8 @@ CPPFLAGS=@CPPFLAGS@ -I$(includedir)
EXTRA_mutt_SOURCES = account.c md5c.c mutt_sasl.c mutt_socket.c mutt_ssl.c \
mutt_tunnel.c pop.c pop_auth.c pop_lib.c smime.c pgp.c pgpinvoke.c pgpkey.c \
pgplib.c sha1.c pgpmicalg.c gnupgparse.c resize.c dotlock.c remailer.c \
- browser.h mbyte.h remailer.h url.h mutt_ssl_nss.c pgppacket.c
+ browser.h mbyte.h remailer.h url.h mutt_ssl_nss.c \
+ pgppacket.c mutt_idna.h
EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO \
configure acconfig.h account.h \
@@ -75,7 +76,7 @@ EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO \
mbyte.h lib.h extlib.c pgpewrap.c smime_keys.pl pgplib.h Muttrc.head Muttrc \
makedoc.c stamp-doc-rc README.SSL smime.h\
muttbug pgppacket.h depcomp ascii.h BEWARE PATCHES patchlist.sh \
- ChangeLog.old mkchangelog.sh cvslog2changelog.pl
+ ChangeLog.old mkchangelog.sh cvslog2changelog.pl mutt_idna.h
mutt_dotlock_SOURCES = mutt_dotlock.c
mutt_dotlock_LDADD = @LIBOBJS@