summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2005-01-28 13:17:22 +0000
committerWerner Koch <wk@gnupg.org>2005-01-28 13:17:22 +0000
commit4bb5db92a89158cc45c3480f2be62d0b435c9a4e (patch)
treeb4cce50c4807558e08925f72ed0f7c3b532cb692 /Makefile.am
parent1cf833351597eb6f991ac0e17a634e8328423014 (diff)
gpgme integration. See documentation for $crypt_use_gpgme,
and http://www.gnupg.org/aegypten2/.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 69585c53..d1d740d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,7 +31,7 @@ mutt_SOURCES = $(BUILT_SOURCES) \
url.c ascii.c mutt_idna.c crypt-mod.c crypt-mod.h
mutt_LDADD = @MUTT_LIB_OBJECTS@ @LIBOBJS@ $(LIBIMAP) $(MUTTLIBS) \
- $(INTLLIBS) $(LIBICONV)
+ $(INTLLIBS) $(LIBICONV) $(LIBGPGME_LIBS)
mutt_DEPENDENCIES = @MUTT_LIB_OBJECTS@ @LIBOBJS@ $(LIBIMAPDEPS) \
$(INTLDEPS)
@@ -53,7 +53,7 @@ DEFS=-DPKGDATADIR=\"$(pkgdatadir)\" -DSYSCONFDIR=\"$(sysconfdir)\" \
-DBINDIR=\"$(bindir)\" -DMUTTLOCALEDIR=\"$(datadir)/locale\" \
-DHAVE_CONFIG_H=1
-INCLUDES=-I. -I$(top_srcdir) $(IMAP_INCLUDES) -Iintl
+INCLUDES=-I. -I$(top_srcdir) $(IMAP_INCLUDES) $(LIBGPGME_CFLAGS) -Iintl
CPPFLAGS=@CPPFLAGS@ -I$(includedir)
@@ -63,7 +63,8 @@ EXTRA_mutt_SOURCES = account.c md5c.c mutt_sasl.c mutt_socket.c mutt_ssl.c \
pgplib.c sha1.c pgpmicalg.c gnupgparse.c resize.c dotlock.c remailer.c \
browser.h mbyte.h remailer.h url.h mutt_ssl_nss.c \
crypt-mod-pgp-classic.c crypt-mod-smime-classic.c \
- pgppacket.c mutt_idna.h hcache.c mutt_ssl_gnutls.c
+ pgppacket.c mutt_idna.h hcache.c mutt_ssl_gnutls.c \
+ crypt-gpgme.c crypt-mod-pgp-gpgme.c crypt-mod-smime-gpgme.c
EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO \
configure acconfig.h account.h \