summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Roessler <roessler@does-not-exist.org>1999-08-24 16:20:55 +0000
committerThomas Roessler <roessler@does-not-exist.org>1999-08-24 16:20:55 +0000
commitc38617e4f29dece4a92b05cc301ee96dd2d52e7d (patch)
tree2fabfabfa1c7c0b3495c7590fe51f51fa11d5921 /Makefile.am
parent78b4191759960e6ceaa732127f5431778b00d174 (diff)
Still more bugs in the release-building process.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index 79e8516b..e7e47fff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -160,23 +160,23 @@ actual-dist:
## This part is maintainer-only and very specific to some
## local settings.
##
- if test $$HOSTNAME = sobolev && test $$LOGNAME = roessler ; then
- pgp -sb $(distdir)i.tar.gz && chmod 644 $(distdir)i.tar.gz.asc
- pgp -sb $(distdir).tar.gz && chmod 644 $(distdir).tar.gz.asc
- if ! ssh-add -l | grep -q roessler@guug.de ; then
- ssh-add
- fi
- @echo "Please connect to the Net and press any key."
- @read dummy
- scp $(distdir){,i}.tar.gz{,asc} \
- sigtrap.guug.de:/home/ftp/pub/mutt/devel/ \
- || echo "UPLOAD FAILED. Please upload manually!"
- cvs commit -m "automatic post-release commit for $(distdir)"
- cvs tag $(distdir)-rel
- cvs update
- $$HOME/bin/upload-mutt
- mutt -s "[Announce] $(distdir) is out" mutt-dev@mutt.org
+ test $$HOSTNAME = sobolev && test $$LOGNAME = roessler
+ ##
+ pgp -sb $(distdir)i.tar.gz && chmod 644 $(distdir)i.tar.gz.asc
+ pgp -sb $(distdir).tar.gz && chmod 644 $(distdir).tar.gz.asc
+ if ! ssh-add -l | grep -q roessler@guug.de ; then ; \
+ ssh-add ; \
fi
+ @echo "Please connect to the Net and press any key."
+ @read dummy
+ scp $(distdir){,i}.tar.gz{,asc} \
+ sigtrap.guug.de:/home/ftp/pub/mutt/devel/ \
+ || echo "UPLOAD FAILED. Please upload manually!"
+ cvs commit -m "automatic post-release commit for $(distdir)"
+ cvs tag `echo $(distdir)-rel | tr . -`
+ cvs update
+ $$HOME/bin/upload-mutt
+ mutt -s "[Announce] $(distdir) is out" mutt-dev@mutt.org
bump-version:
awk -F . '{printf("%d.%d.%d\n", $$1, $$2, $$3 + 1);}' VERSION > _VERSION.$$$$ \