summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Roessler <roessler@does-not-exist.org>1998-10-01 10:06:31 +0000
committerThomas Roessler <roessler@does-not-exist.org>1998-10-01 10:06:31 +0000
commit0651a2d8372ca7b98ffa31e72fba1684401e2664 (patch)
treeaaad7493ddd152114da53f35fdebd6210a1c6e94 /Makefile.am
parent691bd529e512097f427d230c947ff4cf0adb8a38 (diff)
Various automake and installation fixes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e36fee7..21cfc949 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,6 +24,8 @@ BUILT_SOURCES = mutt_dotlock.c
mutt_dotlock.c: dotlock.c
cp dotlock.c mutt_dotlock.c
+CLEANFILES = mutt_dotlock.c
+
LDADD = @LIBOBJS@ @INTLLIBS@
SUBDIRS = doc intl po
@@ -35,3 +37,13 @@ keymap_defs.h: $(OPS)
reldate:
echo 'const char *ReleaseDate = "'`date +%Y-%m-%d`'";' > $(srcdir)/reldate.h
+
+install-exec-local:
+ if test -f $(bindir)/mutt.dotlock && test -f $(bindir)/mutt_dotlock ; then \
+ rm -f $(bindir)/mutt.dotlock ; \
+ ln -sf $(bindir)/mutt_dotlock $(bindir)/mutt.dotlock ; \
+ fi
+ if test -f $(bindir)/mutt_dotlock && test x@DOTLOCK_PERMISSION@ != x ; then \
+ chgrp @DOTLOCK_GROUP@ $(bindir)/mutt_dotlock ; \
+ chmod @DOTLOCK_PERMISSION@ $(bindir)/mutt_dotlock ; \
+ fi