summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix15
1 files changed, 12 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index 28a0f0d380..16bc1f8129 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,9 +1,18 @@
-{ nixroot ? (import <nixpkgs> {})
-, defaultLv2Plugins ? false
+{ defaultLv2Plugins ? false
, lv2Plugins ? []
, releaseMode ? false
}:
-let inherit (nixroot) stdenv pkgs lib
+let
+ nixroot = (import (
+ (import <nixpkgs> {}).fetchFromGitHub {
+ owner = "nixos";
+ repo = "nixpkgs";
+ rev = "df25e214c8e662d693ef89e45ce56bbf58d6c59e";
+ sha256 = "117ir2ysw310q87mndv6czph5qjbhvggmhawcvak6x507yf0dxin";
+ }
+ ) {});
+
+ inherit (nixroot) stdenv pkgs lib
chromaprint fftw flac libid3tag libmad libopus libshout libsndfile lilv
libusb1 libvorbis libebur128 pkgconfig portaudio portmidi protobuf qt5 glib
rubberband sqlite taglib soundtouch vamp opusfile hidapi upower ccache git