summaryrefslogtreecommitdiffstats
path: root/lib/libshout-idjc/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2021-01-16 01:00:10 +0100
committerBe <be@mixxx.org>2021-02-09 15:11:06 -0600
commitd4db6a9e7d94b2f17c927465047302a6c0c46e82 (patch)
tree82231dd5a0dc59ecb8ae892de4947ef20431feed /lib/libshout-idjc/CMakeLists.txt
parent8bf2abf896ab4ebaad2dc48362564db385ca3779 (diff)
CMake: Rewrite Ogg/Vorbis find module
Diffstat (limited to 'lib/libshout-idjc/CMakeLists.txt')
-rw-r--r--lib/libshout-idjc/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/lib/libshout-idjc/CMakeLists.txt b/lib/libshout-idjc/CMakeLists.txt
index 9fd8bfb4ff..ebcbe398b9 100644
--- a/lib/libshout-idjc/CMakeLists.txt
+++ b/lib/libshout-idjc/CMakeLists.txt
@@ -77,8 +77,11 @@ configure_file(include/shoutidjc/shout.h.in "${CMAKE_CURRENT_BINARY_DIR}/include
# Required system dependencies
# Ogg Vorbis
-find_package(OggVorbis REQUIRED)
-target_link_libraries(${PROJECT_NAME} PUBLIC ${OggVorbis_LIBRARIES})
+find_package(Ogg REQUIRED)
+target_link_libraries(${PROJECT_NAME} PUBLIC Ogg::ogg)
+
+find_package(Vorbis REQUIRED)
+target_link_libraries(${PROJECT_NAME} PUBLIC Vorbis::vorbis Vorbis::vorbisenc)
# Optional system dependencies
find_package(OpenSSL)