summaryrefslogtreecommitdiffstats
path: root/lib/libshout-idjc/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2021-03-16 01:28:27 +0100
committerJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2021-03-16 13:14:18 +0100
commita90d8f18eee7cf3cef10625f1823c6606ff1c0ef (patch)
treede68ab4226990ec2b6ac00b58407662f76147ca8 /lib/libshout-idjc/CMakeLists.txt
parent2d7464d0cc0874e4d854ca9b683e567ab3b20ca1 (diff)
CMake: Require OpenSSL for building libshout-idjc on Linux
Diffstat (limited to 'lib/libshout-idjc/CMakeLists.txt')
-rw-r--r--lib/libshout-idjc/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/lib/libshout-idjc/CMakeLists.txt b/lib/libshout-idjc/CMakeLists.txt
index e33a835ea7..02b794b6ba 100644
--- a/lib/libshout-idjc/CMakeLists.txt
+++ b/lib/libshout-idjc/CMakeLists.txt
@@ -75,12 +75,10 @@ target_link_libraries(${PROJECT_NAME} PUBLIC Ogg::ogg)
find_package(Vorbis REQUIRED)
target_link_libraries(${PROJECT_NAME} PUBLIC Vorbis::vorbis Vorbis::vorbisenc)
-# Optional system dependencies
-find_package(OpenSSL)
-if(TARGET OpenSSL::SSL)
- target_compile_definitions(${PROJECT_NAME} PRIVATE HAVE_OPENSSL)
- target_link_libraries(${PROJECT_NAME} PRIVATE OpenSSL::SSL OpenSSL::Crypto)
-endif()
+# OpenSSL
+find_package(OpenSSL REQUIRED)
+target_compile_definitions(${PROJECT_NAME} PRIVATE HAVE_OPENSSL)
+target_link_libraries(${PROJECT_NAME} PRIVATE OpenSSL::SSL OpenSSL::Crypto)
option(SPEEX "Speex support" OFF)
if(SPEEX)