summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Schürmann <daschuer@mixxx.org>2020-04-28 16:27:33 +0200
committerDaniel Schürmann <daschuer@mixxx.org>2020-04-28 16:32:08 +0200
commitebce93ede0ceeaab682fd403e372ac0d6bf9d384 (patch)
treeb801139e607755f358557fb4d29b5b776efaf6ce /CMakeLists.txt
parenta322841793cb0eb5efa29b12b0444001c1dca519 (diff)
actually link against internal shout_mixxx
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d79845115..1f1d2567db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1880,10 +1880,14 @@ if(BROADCAST)
# Fall back to internal libraray in the lib tree
message(STATUS "Preparing internal Shout")
add_subdirectory("${CMAKE_CURRENT_SOURCE_DIR}/lib/libshout")
+ target_include_directories(mixxx-lib PUBLIC lib/libshout/include)
+ target_link_libraries(mixxx-lib PUBLIC shout_mixxx)
+ else()
+ target_link_libraries(mixxx-lib PUBLIC Shout::Shout)
endif()
else()
if(NOT Shout_FOUND)
- message(FATAL_ERROR "Live Broadcasting support requires the libshout and its development headers.")
+ message(FATAL_ERROR "Live Broadcasting support requires the libshout and its development headers.")
endif()
target_link_libraries(mixxx-lib PUBLIC Shout::Shout)
endif()