summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBe <be@mixxx.org>2020-11-14 21:15:34 -0600
committerBe <be@mixxx.org>2020-11-18 14:13:10 -0600
commite7cf360d04ce2ecb0b41d4774f5ae52f8d076d70 (patch)
tree04460e34c095dc84a5b5e6e1f776f295f59dad51 /CMakeLists.txt
parent133ea1e3d6547964f014144eee15590ea449c7af (diff)
CMake: fix macOS build for macOS < 10.14
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bab90d6be9..fc51718306 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,10 @@ else()
set(LLVM_CLANG false)
endif()
+if(APPLE AND CMAKE_OSX_DEPLOYMENT_TARGET VERSION_LESS 10.14)
+ add_compile_options(-fno-aligned-allocation)
+endif()
+
# CMake implicitly sets the variable MSVC to true for Microsoft
# Visual C++ or another compiler simulating Visual C++.
# https://cmake.org/cmake/help/latest/variable/MSVC.html
@@ -1074,7 +1078,6 @@ if (APPLE)
set(MACOS_BUNDLE_VERSION "${CMAKE_PROJECT_VERSION}")
set(MACOS_BUNDLE_SHORTVERSION "${CMAKE_PROJECT_VERSION}")
- set(MACOS_BUNDLE_MINOSVERSION "10.12.0")
set_target_properties(mixxx PROPERTIES
MACOSX_BUNDLE true