summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorUwe Klotz <uklotz@mixxx.org>2021-03-17 13:17:00 +0100
committerUwe Klotz <uklotz@mixxx.org>2021-03-17 13:18:29 +0100
commite402aaeda14a4b5e7bff9ad3c7701c616c8db7dd (patch)
tree217b627a89be3baa22ac5bf298422fccf0609a9b /CMakeLists.txt
parent058c38805147140d940845fe4fe6cdfb809dc42d (diff)
Use cmake_dependent_option() for WavPack consistently
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7442de4f6f..934b5930e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2622,9 +2622,9 @@ endif()
# WavPack audio file support
find_package(wavpack)
-option(WAVPACK "WavPack audio file support" OFF)
+cmake_dependent_option(BULK "WavPack audio file support" ON "wavpack_FOUND" OFF)
if(WAVPACK)
- if(NOT TARGET WavPack::wavpack)
+ if(NOT wavpack_FOUND)
message(FATAL_ERROR "WavPack audio file support requires libwv and its development headers.")
endif()
target_sources(mixxx-lib PRIVATE src/sources/soundsourcewv.cpp)