summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBe <be@mixxx.org>2021-03-07 12:21:54 -0600
committerBe <be@mixxx.org>2021-03-07 12:21:54 -0600
commitddbc5f9e9f94f9180d9d0cd757f810c9b05824fc (patch)
treeb714f806184f60e5007ec338830ce31cf741817c /CMakeLists.txt
parent3f7d6ebbee8b1a894bab6e94b4a409ecef216f68 (diff)
CMake: add comment why /OPT:ICF is not used
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b5aaf248f..9fab375020 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,6 +134,8 @@ if(MSVC)
string(REPLACE "/RTC1" "" CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG}")
else()
# Reduce the size of the binary in Release & RelWithDebInfo builds
+ # Do not use /OPT:ICF because it has no effect.
+ # https://github.com/mixxxdj/mixxx/pull/3660#pullrequestreview-600137258
add_link_options(/OPT:REF)
# /INCREMENTAL is incompatible with /OPT:REF
string(REPLACE "/INCREMENTAL" "/INCREMENTAL:NO" CMAKE_EXE_LINKER_FLAGS_RELEASE "${CMAKE_EXE_LINKER_FLAGS_RELEASE}")