summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorUwe Klotz <uklotz@mixxx.org>2020-11-13 00:18:35 +0100
committerUwe Klotz <uklotz@mixxx.org>2020-11-13 17:21:55 +0100
commitd0e5653ef4071d4f13823edb2c8d6258d865084c (patch)
treee12fe66bbfc02b6fb730ff0799ce5722e367dfe9 /CMakeLists.txt
parent1c9f6aceee3ac0b28aa36f43be031c843a705af8 (diff)
Upgrade to libusb/hidapi v0.10.0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2c7aa95671..012a68937a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2327,6 +2327,10 @@ if(HID)
target_sources(mixxx-hidapi PRIVATE lib/hidapi/windows/hid.c)
elseif(APPLE)
target_sources(mixxx-hidapi PRIVATE lib/hidapi/mac/hid.c)
+ find_library(APPKIT_LIBRARY AppKit REQUIRED)
+ target_link_libraries(mixxx-lib PUBLIC
+ ${APPKIT_LIBRARY}
+ )
elseif(UNIX)
if(NOT LibUSB_FOUND)
message(FATAL_ERROR "USB HID controller support on Unix with statically linked libhidapi-libusb requires libusb 1.0 and its development headers.")