summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-11-27 15:51:05 +0100
committerJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-11-28 15:04:10 +0100
commitcb4ab3d6c96745768f3573dbefa11e6704d4007d (patch)
treee95f85afae0baeb94c21489bed1362f4e3c98aef /CMakeLists.txt
parent7760fc03e3ee998de2f4ce82b55e10b776c10699 (diff)
CMake: Suppress MSVC warnings in generated code
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index afc168c76b..d17a8c4855 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -939,6 +939,17 @@ if(GNU_GCC OR LLVM_CLANG)
APPEND_STRING
PROPERTY COMPILE_OPTIONS -Wno-unused-parameter -Wno-switch
)
+elseif(MSVC)
+ set_property(
+ SOURCE src/library/rekordbox/rekordbox_anlz.cpp
+ APPEND_STRING
+ PROPERTY COMPILE_OPTIONS /w
+ )
+ set_property(
+ SOURCE src/library/rekordbox/rekordbox_pdb.cpp
+ APPEND_STRING
+ PROPERTY COMPILE_OPTIONS /w
+ )
endif()
option(WARNINGS_PEDANTIC "Let the compiler show even more warnings" OFF)