summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Schürmann <daschuer@mixxx.org>2020-12-09 20:07:09 +0100
committerDaniel Schürmann <daschuer@mixxx.org>2020-12-10 07:44:42 +0100
commitc5890568f453ebf4384aeec19b885a28f7c5352e (patch)
treeb234b52c55abb4e7b6c6ab4358c8ae7dc579ef54 /CMakeLists.txt
parentf2b93a75eed246038d60382da329aeccafe71e00 (diff)
Use System Fonts
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 20 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 245ef342cd..98e3d58f95 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1205,13 +1205,26 @@ install(
"*.qm"
)
+
# Font files
-install(
- DIRECTORY
- "${CMAKE_CURRENT_SOURCE_DIR}/res/fonts"
- DESTINATION
- "${MIXXX_INSTALL_DATADIR}"
-)
+if(UNIX AND NOT APPLE)
+ # Ubuntu and OpenSans are already installed by package manager
+ install(
+ DIRECTORY
+ "${CMAKE_CURRENT_SOURCE_DIR}/res/fonts"
+ DESTINATION
+ "${MIXXX_INSTALL_DATADIR}"
+ PATTERN "OpenSans*" EXCLUDE
+ PATTERN "Ubuntu*" EXCLUDE
+ )
+else()
+ install(
+ DIRECTORY
+ "${CMAKE_CURRENT_SOURCE_DIR}/res/fonts"
+ DESTINATION
+ "${MIXXX_INSTALL_DATADIR}"
+ )
+endif()
# Keyboard mapping(s)
install(
@@ -2538,7 +2551,7 @@ set(CPACK_DEBIAN_PACKAGE_SECTION "sound")
set(CPACK_DEBIAN_PACKAGE_PRIORITY "optional")
set(CPACK_DEBIAN_PACKAGE_SUGGESTS "pdf-viewer, pulseaudio-utils")
set(CPACK_DEBIAN_PACKAGE_REPLACES "mixxx-data")
-set(CPACK_DEBIAN_PACKAGE_DEPENDS "libqt5sql5-sqlite")
+set(CPACK_DEBIAN_PACKAGE_DEPENDS "libqt5sql5-sqlite, fonts-open-sans, fonts-ubuntu")
set(CPACK_DEBIAN_PACKAGE_SHLIBDEPS ON)
set(CPACK_DEBIAN_PACKAGE_HOMEPAGE "${CPACK_PACKAGE_HOMEPAGE_URL}")
file(READ ${CPACK_PACKAGE_DESCRIPTION_FILE} CPACK_DEBIAN_PACKAGE_DESCRIPTION)