summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Schürmann <daschuer@mixxx.org>2021-01-24 00:23:57 +0100
committerDaniel Schürmann <daschuer@mixxx.org>2021-01-24 00:23:57 +0100
commita9b115c26618a24b5f038784b4998310ea409d3f (patch)
tree5a1ae24a1a2c1f3b2a1d120bbaef2f97519375aa /CMakeLists.txt
parent7de4f9c3d74afc1b946052cc3034798502b15c66 (diff)
Don't use InstallRequiredSystemLibraries on Linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a43f49622b..992db32a81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1141,7 +1141,9 @@ if (APPLE)
MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/packaging/macos/bundle.plist.in"
)
endif()
-else()
+endif()
+
+if(WIN32)
set(CMAKE_INSTALL_SYSTEM_RUNTIME_DESTINATION "${MIXXX_INSTALL_BINDIR}")
if(MSVC AND CMAKE_BUILD_TYPE STREQUAL "Debug")
set(CMAKE_INSTALL_DEBUG_LIBRARIES true)