summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-04-24 14:59:38 +0200
committerJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-04-25 15:46:01 +0200
commit8b994d309c4240cec117659f68ba63bee0564b31 (patch)
tree3bbe75598f933be17a251934522bddc20a332912 /CMakeLists.txt
parent0c2a0368f6e3910e018dd1c6712dd7cb510834f9 (diff)
track/serato: Determine timing offsets when audio signal properties are known
Sometimes, cue offsets depend on audio signal properties such as the track's sample rate. This is the case for cues imported from Serato when the track is imported with the MAD decoder. Before, the timing offsets were determined before the sample rate is known. This change allows postponing the offset calculation until the audio signal properties are known. Zulip Discussion: https://mixxx.zulipchat.com/#narrow/stream/109171-development/topic/Serato.20cue.20import/near/195090899 fixup
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d40beda92a..7514a640d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -551,12 +551,14 @@ add_library(mixxx-lib STATIC EXCLUDE_FROM_ALL
src/track/bpm.cpp
src/track/cue.cpp
src/track/cueinfo.cpp
+ src/track/cueinfoimporter.cpp
src/track/globaltrackcache.cpp
src/track/keyfactory.cpp
src/track/keys.cpp
src/track/keyutils.cpp
src/track/playcounter.cpp
src/track/replaygain.cpp
+ src/track/serato/cueinfoimporter.cpp
src/track/serato/markers.cpp
src/track/serato/markers2.cpp
src/track/serato/tags.cpp