summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorUwe Klotz <uklotz@mixxx.org>2020-11-29 11:02:19 +0100
committerUwe Klotz <uklotz@mixxx.org>2020-11-29 11:36:21 +0100
commit82a9eb570bfa52af1d92bb319b122bce6f34e594 (patch)
treec050a0f71b1891c344132436b0e3c5c5d52286dd /CMakeLists.txt
parent7f3fae237c36a5d1729f0e8f6f2ec547ae4b5869 (diff)
Windows: Define minimum version in CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34a1b8823d..c57973d5e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1005,8 +1005,14 @@ if(APPLE)
endif()
# Windows-specific options
-if(MSVC)
- target_compile_definitions(mixxx-lib PUBLIC _USE_MATH_DEFINES)
+if(WIN32)
+ # https://docs.microsoft.com/en-us/cpp/porting/modifying-winver-and-win32-winnt
+ # _WIN32_WINNT_WIN7 = 0x0601
+ target_compile_definitions(mixxx-lib PUBLIC WINVER=0x0601)
+ target_compile_definitions(mixxx-lib PUBLIC _WIN32_WINNT=0x0601)
+ if(MSVC)
+ target_compile_definitions(mixxx-lib PUBLIC _USE_MATH_DEFINES)
+ endif()
endif()
#