summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorUwe Klotz <uklotz@mixxx.org>2020-11-29 10:45:41 +0100
committerUwe Klotz <uklotz@mixxx.org>2020-11-29 11:02:36 +0100
commit7f3fae237c36a5d1729f0e8f6f2ec547ae4b5869 (patch)
tree93b3c1cb6848122fcc69a47bf88e912e064758cb /CMakeLists.txt
parent2bde5088a448ddd3000c268db6f160d8cfe5d318 (diff)
Windows: Remove obsolete _ATL_XP_TARGETING define
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b4aea98ebc..34a1b8823d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1034,10 +1034,6 @@ endif()
if(WIN32)
target_compile_definitions(mixxx-lib PRIVATE __WINDOWS__)
- # Restrict ATL to XP-compatible SDK functions.
- # TODO(rryan): Remove once we ditch XP support.
- target_compile_definitions(mixxx-lib PUBLIC _ATL_XP_TARGETING)
-
# Helps prevent duplicate symbols
target_compile_definitions(mixxx-lib PUBLIC _ATL_MIN_CRT)