summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorUwe Klotz <uklotz@mixxx.org>2021-03-19 18:26:00 +0100
committerUwe Klotz <uklotz@mixxx.org>2021-03-19 18:26:00 +0100
commit7d52868c6c6fba51e5fca01c92a97ea0f00b3a1c (patch)
treeaa2fe62805387adfe9a37c875624edac0d9c950d /CMakeLists.txt
parent7866dea6e4ad38392040ea37739feba4ae8cceae (diff)
CMake: Fix detection of hidapi_VERSION
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2dc762d5d0..be67c340d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2536,7 +2536,8 @@ find_package(LibUSB)
# USB HID controller support
find_package(hidapi)
option(HID "USB HID controller support" ON)
-default_option(HIDAPI_STATIC "Link HIDAPI library statically" "NOT HIDAPI_FOUND")
+# hidapi_VERSION is only available starting with 0.10.0
+default_option(HIDAPI_STATIC "Link HIDAPI library statically" "NOT hidapi_FOUND OR NOT hidapi_VERSION OR hidapi_VERSION VERSION_LESS 0.10.0")
if(HID)
target_sources(mixxx-lib PRIVATE
src/controllers/hid/hidcontroller.cpp