summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBe <be@mixxx.org>2020-11-10 22:18:06 -0600
committerBe <be@mixxx.org>2020-11-11 09:08:06 -0600
commit691233fbe4c7495a08a77526fbd3aed7ebd47619 (patch)
treeae7ff2fcc80151f4adfdfe183e08d14c83352eac /CMakeLists.txt
parent671b50d2a4a3f23179ce6588a8cc602d2d0d5082 (diff)
fix macOS bundle build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd74736d06..60b4478a91 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -979,6 +979,15 @@ target_compile_definitions(mixxx-lib PUBLIC
$<$<NOT:$<CONFIG:Debug>>:NDEBUG>
)
+# Mac-specific options
+if(APPLE)
+ option(MACOS_BUNDLE "Install files to proper locations to make an .app bundle" OFF)
+ option(MACAPPSTORE "Build for Mac App Store" OFF)
+ if(MACAPPSTORE)
+ target_compile_definitions(mixxx-lib PUBLIC __MACAPPSTORE__)
+ endif()
+endif()
+
#
# Installation directories
#
@@ -1062,7 +1071,7 @@ if (APPLE)
set(MACOS_BUNDLE_VERSION "${CMAKE_PROJECT_VERSION}")
set(MACOS_BUNDLE_SHORTVERSION "${CMAKE_PROJECT_VERSION}")
set(MACOS_BUNDLE_MINOSVERSION "10.11.0")
-
+
set_target_properties(mixxx PROPERTIES
MACOSX_BUNDLE true
MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/cmake/macos_bundle.plist.in"
@@ -2246,15 +2255,6 @@ if(MAD)
target_link_libraries(mixxx-lib PUBLIC MAD::MAD ID3Tag::ID3Tag)
endif()
-# Mac App Store
-if(APPLE)
- option(MACAPPSTORE "Build for Mac App Store" OFF)
- if(MACAPPSTORE)
- target_compile_definitions(mixxx-lib PUBLIC __MACAPPSTORE__)
- endif()
- option(MACOS_BUNDLE "Install files to proper locations to make an .app bundle" OFF)
-endif()
-
# Media Foundation AAC Decoder Plugin
find_package(MediaFoundation)
cmake_dependent_option(MEDIAFOUNDATION "Media Foundation AAC decoder plugin (Windows Vista with KB2117917 or Windows 7 required)" ON "MediaFoundation_FOUND" OFF)