summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-11-27 00:25:33 +0100
committerJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-11-28 15:04:10 +0100
commit5c39548f0cc3dad633f99658e4c8443423db0352 (patch)
treeeda52f2f3cbca40ba16430386ba0d951ea092256 /CMakeLists.txt
parented099d1beb5b2bf3deced0302d8f9b03bdddab7d (diff)
CMake: Silence MSVC std::iterator deprecation warnings
the ware caused by protobuf lib.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9d1b12ae86..2bc9bf8ac6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -947,6 +947,7 @@ if(MSVC)
target_compile_options(mixxx-lib PUBLIC /W4)
else()
target_compile_options(mixxx-lib PUBLIC /W3)
+ target_compile_definitions(mixxx-lib PUBLIC _SILENCE_CXX17_ITERATOR_BASE_CLASS_DEPRECATION_WARNING)
endif()
else()
target_compile_options(mixxx-lib PUBLIC -Wall -Wextra -Wfloat-conversion)