summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBe <be@mixxx.org>2020-12-09 08:38:15 -0600
committerBe <be@mixxx.org>2020-12-09 08:38:15 -0600
commit5769404031d701c85dc0912fb1d7ed0433e833d3 (patch)
treeb8b298e6eda5518e94e9d6b573ea6e76f551c0c5 /CMakeLists.txt
parent1691d4c37c3d1b357473f5cf93f2a211f56fcd0a (diff)
CMake: always link CoreFoundation on macOS
This should not depend on whether the CoreAudio feature is being built.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 303f47ab0a..3e91791984 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2039,6 +2039,9 @@ endif()
# iOS/OS X Frameworks
if(APPLE)
+ find_library(COREFOUNDATION_LIBRARY CoreFoundation REQUIRED)
+ target_link_libraries(mixxx-lib PUBLIC ${COREFOUNDATION_LIBRARY})
+
# The iOS/OS X security framework is used to implement sandboxing.
find_library(SECURITY_LIBRARY Security REQUIRED)
target_link_libraries(mixxx-lib PUBLIC ${SECURITY_LIBRARY})
@@ -2127,11 +2130,7 @@ if(COREAUDIO)
lib/apple/CAStreamBasicDescription.cpp
)
find_library(AUDIOTOOLBOX_LIBRARY AudioToolbox REQUIRED)
- find_library(COREFOUNDATION_LIBRARY CoreFoundation REQUIRED)
- target_link_libraries(mixxx-lib PUBLIC
- ${AUDIOTOOLBOX_LIBRARY}
- ${COREFOUNDATION_LIBRARY}
- )
+ target_link_libraries(mixxx-lib PUBLIC ${AUDIOTOOLBOX_LIBRARY})
target_compile_definitions(mixxx-lib PRIVATE __COREAUDIO__)
target_include_directories(mixxx-lib SYSTEM PUBLIC lib/apple)
endif()